Question

Characters getting prepended by ^[ while setting up changes to php ini

Posted September 2, 2016 1.6k views
NginxPHP

Hi,

I had made some changes to my php5 ini file and wanted to save and exit. I may have typed Control + ^X or something in the console. All of a sudden it redirected me to login again and now whenever a type a letter it gets prepended by ^[ characters. For eg, typing d will appear as ^[d. How do I exit from this program. I am not using SSH to access the console but directly from the website.

Regards
Sushanta

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Generally we recommend using the console only for emergency access to your droplet and that you perform regular maintenance and administration via an ssh client.

If you find these characters being inserted into the text you’re typing in the console, try pressing Ctrl and Alt a few times. This should reset the keymap for the console and correct the issue.

Hello, all

The Copy/Paste functionality of our web console is a bit odd; the code backing it is custom due to the way the VNC window is implemented for accessing your Droplet. It isn’t a good idea, in my experience, to rely on the console for long copy/pasting like an SSH key.

My recommended method to get the key on the Droplet is over SSH itself. Also the web console is intended to access your droplet in a case of emergency in order to sort out the issue. I will highly recommend to use a ssh-client in order to access and manage your droplet.

You can also check our docs on How to Connect to Droplets with SSH:

https://www.digitalocean.com/docs/droplets/how-to/connect-with-ssh/

There are two options at the bottom of the doc:
Connect with OpenSSH
and
Connect with PuTTY

You can enable PasswordAuthentication for your Droplet by modifying your /etc/ssh/sshd_config file. Once set to Yes restart the SSH service and connect via an SSH client for a more stable connection. You can then modify your ~/.ssh/authorized_keys file to add the appropriate public key.

This should do the job for you as well.

The other option is to temporary enable the PasswordAuthentication from no to yes in order to access your droplet using password and then once you’ve entered your key to disable the PasswordAuthentication again. This way is considered more secure than uploading the key to a Dropbox in case you don’t have any other server to us.

  1. Login to the console on DigitalOcean website.
  2. Type sudo nano /etc/ssh/sshd_config
  3. Change PasswordAuthentication from “no” to “yes” and save the file
  4. Open a terminal on your computer and type ssh username@[hostname or IP address] or if on a Windows box use PuTTY for password login making sure authentication parameters aren’t pointing to a private key
  5. Login with password
  6. Type sudo nano ~/.ssh/authorized_keys
  7. Paste public key text here and save the file
  8. Type sudo nano /etc/ssh/sshd_config
  9. Change PasswordAuthentication from “yes” to “no” and save the file
  10. Log out and attempt to log back in (if using PuTTY make sure you set up auth parameters to point to your private key)

Hope that this helps!
Regards,
Alex