Client cannot access a subdomain, even though I can

So I set up the client’s domain subdomain to a droplet, which serves as their “backend”. I can access the website fine on, on mobile, browsers and different browsers or computers. The DNS is handled by digital ocean, and I have confirmed this is working.

When the client attempts to access the subdomain on a safari browser (mac computer), it just reroutes to the main domain. When giving them the IP of the droplet, it just loads a white screen. The droplet has a Wordpress site from the marketplace loaded on it.

The site is also https encrypted with lets-encrypt.

I have

  1. Switched off the UFW firewall - no difference
  2. Asked the client to clear the cache from their browser / try different browsers - no difference
  3. Ran a traceroute from my side to the subdomain, which looks like its working fine.

The website is the default Wordpress one from the marketplace, I have the default apache2 conf, and in /var/html/.htaccess I have this (to redirect to the admin panel, as this is used as a CMS).

RedirectMatch ^/$ /wp-admin

λ tracert

Tracing route to []
over a maximum of 30 hops:

  1    11 ms     5 ms     6 ms []
  2    17 ms    22 ms    38 ms
  3    57 ms    25 ms    18 ms []
  4    21 ms    24 ms    25 ms []
  5     *        *        *     Request timed out.
  6    28 ms    16 ms    29 ms []
  7     *        *        *     Request timed out.
  8    18 ms    21 ms    19 ms []
  9    22 ms    20 ms    26 ms []
 10     *       21 ms     * []
 11    21 ms    20 ms    16 ms []
 12    29 ms    19 ms    18 ms []
 13     *        *        *     Request timed out.
 14     *        *        *     Request timed out.
 15    27 ms    19 ms     *
 16    19 ms    20 ms    16 ms

Trace complete.

I’m running out of ideas, besides it being an issue with the client’s ISP.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Site Moderator
Site Moderator badge
May 11, 2020
Accepted Answer

Hi @afletcher,

This sounds really interesting! I’ve just tried to :

  • Open your Droplet’s IP in the browser
  • Ping the Domain it shows
  • Do a CURL request to see the headers it returns.

I can confirm everything looks to be working perfectly well. Having said that, had you made any changes to the Apache’s Vhost files of the domain? Maybe the issue lied there.

Alternatively, my suggestion might have been a router cache as I have seen this, and after a reboot of the router everything worked perfectly.

Can you confirm what was it as this is something I would like to know as well?

Regards, KDSys


It was indeed the user’s router cache (I did not even know they had them!?).

I got the client to access the site at work, and it loaded as normal. As all their devices were connected to the router, after power-cycling it started to work properly.

Thanks for your help!

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel