Question

Cloue Firewall: How to open port 6002 for Websockets?

In my Inbound Rules I’ve set these rules:

Type: Custom Protocol: TCP Portrange: 6002 for IPv4 and 6

But still if I go to https://ping.eu/port-chk/ my port is still closed!

Any ideas?

I don’t use the local firewall only the DO Cloud Firewall


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hello, @avidofood

If you’re running on Ubuntu droplet you can try to open the port on ufw and then to disable it again. I had a similar issue and this helped.

sudo ufw allow 6002
sudo ufw disable

Is you’re application already listening on this port or have an active connection?

You can also test the connection using telnet:

telnet IPaddr 6002

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.