Question

Configuring Docker to Use the Remote Host Throwing Error.

I tried to configure docker running in my laptop (Windows 10 Pro) to use the remote host but it throws error. I tried the below steps

PS C:\Users\Sanjay> export DOCKER_HOST=ssh://root@167.71.XXX.XXX

167.71.XXX.XXX is my droplet IP.

but it throws the error -

export : The term 'export' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

At line:1 char:1
+ export DOCKER_HOST=ssh://root@167.71.XXX.XXX
+ ~~~~~~
    + CategoryInfo          : ObjectNotFound: (export:String) [], CommandNotFoundException
    + FullyQualifiedErrorId : CommandNotFoundException

please help me to solve this issue.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @skriss03, by looking at the prompt it looks like you are using Windows Powershell and equivalent of export on Windows Powershell would be as follows.

set DOCKER_HOST=ssh://root@167.71.XXX.XXX

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.