Question

Conflicting server name "mydomain.com" on 0.0.0.0:80, ignored NGINX error log Ubuntu 20.04

Posted October 12, 2020 24.7k views
Nginx

Hello, when I check the nginx error log I notice that alert and I don’t know why, I cannot access my website from http or https, my DNS in cloudflare are:

A - mydomain.com - MY IP
CNAME - www - mydomain.com

The 4 last lines of the log:

2020/10/12 07:03:22 [notice] 15705#15705: signal process started
2020/10/12 07:18:50 [warn] 15818#15818: conflicting server name "mydomain.com" on 0.0.0.0:80, ignored
2020/10/12 07:18:50 [warn] 15818#15818: conflicting server name "www.mydomain.com" on 0.0.0.0:80, ignored
2020/10/12 07:54:16 [notice] 16047#16047: signal process started

Any help please?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hi there @hcmendez,

It most likely means that you have your mydomain.com domain specified in multiple Nginx server blocks.

What you could do is use the grep command and search for the mydomain.com domain inside your /etc/nginx/sites-enabled folder:

  • grep -r mydomain.com /etc/nginx/sites-enabled

If you see the domain name in more than server blocks for port 80, you would need to remove the duplicate one and then restart Nginx.

Hope that this helps!
Regards,
Bobby

  • Thanks for the answer, i’m typing the command but nothing happens. I have changed the mydomain.com with my real domain but nothing.

  • same is happening to me, what to do when I need to host multiple sites on several created server blocks in /etc/nginx/sites-available/

    ps. all my domains in cloudflare

  • Wow, thanks a ton. I read over this and thought “there’s absolutely no way I’m specifying multiple domains, I’ve been over my files multiple times” but ran it anyways. It looks like certbot for whatever reason decided to overwrite my default site server_name with a new site I’d created in a separate file…? Likely because I was using an older version with bugs

    Just so that everybody is aware, you’ll likely have to include a wildcard in the search for it to return results:

    grep -r mydomain.com /etc/nginx/sites-enabled/*
    
    • Hi there,

      Happy to hear that you’ve got it all working! Thank you for including this additional information here!

      • Hello,
        I just had the same problem and used the code snippet to find my IP showed red (meaning it’s on server blocks). How do I remove it. There is only one place i kept the IP

        Please see my configuration:
        dir: /etc/nginx/sites-enalbed/clouditech

        code
        
        server {  
            listen 80;     
            server_name 137.184.69.187;    
            location = /favicon.ico { access_log off; log_not_found off; }    
            location /static/ {         
                root /root/clouditech_project;     
            }    
            location / {         
                include proxy_params;         
                proxy_pass http://unix:/run/gunicorn.sock;     
            }
        }
        
        
        

Thanks for the answers, I deployed another droplet with Open LiteSpeed. Everything is good now, thanks.