copy-paste doesn't work from your console

Posted February 4, 2017 42.4k views

How the heck do I copy or paste anything from the web console? I’ve tried both Safari and Chrome. I’m trying to get ssh to work but I can’t copy/paste keys or get authorized any other way.

  • Friends after ~40 min of frustration trying to copy-and-paste my original password on my first login from my Chromebook, I found an easy solution.

    1) Install the “Secure Shell” chrome extension
    2) run it, enter your droplet’s IP and username as “root”
    3) connect
    4) now for the trick: copy your password as it came on the email, and to paste it do not use CTRL-V but CTRL-SHIFT-V


  • as of 2022, i don’t even know how to select text!

    but much appreciated for even providing a web console. It’s really handy on my iOS device as the connection stays open, and even re-connects really well! Just need to make the signal functions work..

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
21 answers

I got it. I just needed to ssh in as root to set everything up.

  • @pjpark

    Glad you were able to get things working!

    For future reference, on most OS’s, root is the default user you’ll need to use to login initially. CoreOS is one exception.

    If you run in to any other issues, feel free to reply and I’ll be more than happy to help!

I still can’t copy and paste into the console. I need to update my authorized keys and what should take 2 minutes is taking more than an hour, with still no resolution in sight.

Edit: What I ended up doing was copying my to a public server, wgeting it to my DO, and then yanking and pasting into `~/.ssh/authorizedkeys` with vim.

You know how I got this to work after not finding any workable solution?? Logged into console, edited ~/.ssh/authorized_keys using NANO and manually typed out the new ssh key…

Was locked out due to disabling password authentication and Permission denied (publickey).

On a Mac, wrote an AppleScript to type.

In Script Editor located /Applications/Utilities/Script Editor

tell application "System Events"
    set textToType to "ssh-rsa AAAAB..."
    delay 20
    repeat with i from 1 to count characters of textToType
        keystroke (character i of textToType)
        delay 0.6
    end repeat
end tell

Make sure to have ~/.ssh/authorized_keys already open in an editor and in insert mode waiting to type

Press play

After a 20 second delay (hopefully, enough time to change to the console browser window ready for the typing to start) this will type the text inside set textToType to emulating keystrokes

Same problem here: Reversed capitalisation; Cannot Copy/Paste.
Why am I having problems I had during the 1980’s on DEC Terminal on a 2400 baud modem?
Very frustrating.
Just trying to update my authorized_keys since SSH gives “Permission denied (public key)”.

this is still a problem for me in 2019. How is this like this?

2020, pasting anything into your default console results in different text. WTF digitalocean? Is this a joke?


If you’re on a MacBook / MacBook Pro, the best option is to use Terminal or Hyper – on Windows, it’s best to use PuTTy.

The console that’s available through the DigitalOcean Control Panel requires that you type in input – you won’t be able to CMD+V or CTRL+V it in.

Hey everyone,
I am a product manager here at DigitalOcean and I wanted to send a quick update about this issue. We just released the ability to paste text into our Cloud Console! Give it a try and let us know if there is anything else we can help with.

  • Hey, I just tried and it still doesn’t work.

  • It only pastes a small amount of characters. Trying to paste a public key fails miserably.

  • Hi Keith,

    Copying and pasting still does not seem to work. It seems to be the main use case for this feature would be copying+pasting ssh keys to provide access.

    Is it possible to instead of working on this feature instead, add the ability to add root access ssh keys via the droplet gui manager on the main website? Kind of like how we manage our ssh keys on

    Just my 2c and thank you for your efforts!

There are several answers provided that will definitely work. I figured I’d also share mine.

  1. Enable ssh password authentication
  2. ssh using your normal terminal so you can copy and paste like normal
  3. Disable password authentication for security

Little more work but, it’s straightforward.

Previous 1 2 3 Next