tamasd79
By:
tamasd79

Creating a subdomain on LEMP?

November 24, 2017 119 views
Nginx Ubuntu 16.04

Hi,

I have a droplet, I used the one-click install with LEMP.

I've been having trouble with adding a subdomain. Here is what I'm doing.

  1. I set up the domain and pointed it to my server.

  2. I also created an A record for my subdomain sub.mydomain.com

  3. I created a new directory for my subdomain using the following comand: sudo mkdir -p /var/www/sub.mydomain.com/html

  4. I also did this: sudo chown -R $USER:$USER /var/www/sub.mydomain.com/html

  5. I created a new server block using the following command:
    sudo cp /etc/nginx/sites-available/default /etc/nginx/sites-available/sub.mydomain.com

  6. Here I'm trying to modify my server block and I think this is where I'm doing something wrong

##
# You should look at the following URL's in order to grasp a solid understanding
# of Nginx configuration files in order to fully unleash the power of Nginx.
# http://wiki.nginx.org/Pitfalls
# http://wiki.nginx.org/QuickStart
# http://wiki.nginx.org/Configuration
#
# Generally, you will want to move this file somewhere, and start with a clean
# file but keep this around for reference. Or just disable in sites-enabled.
#
# Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.
##

# Default server configuration
#
server {
    listen 80 default_server;
    listen [::]:80 default_server;

    # SSL configuration
    #
    # listen 443 ssl default_server;
    # listen [::]:443 ssl default_server;
    #
    # Note: You should disable gzip for SSL traffic.
    # See: https://bugs.debian.org/773332
    #
    # Read up on ssl_ciphers to ensure a secure configuration.
    # See: https://bugs.debian.org/765782
    #
    # Self signed certs generated by the ssl-cert package
    # Don't use them in a production server!
    #
    # include snippets/snakeoil.conf;

    root /var/www/html;

    # Add index.php to the list if you are using PHP
    index index.php index.html index.htm index.nginx-debian.html;

    server_name sub.mydomain.com;

    location / {
        # First attempt to serve request as file, then
        # as directory, then fall back to displaying a 404.
        try_files $uri $uri/ =404;
    }

    # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
    #
    #location ~ \.php$ {
    #   include snippets/fastcgi-php.conf;
    #
    #   # With php7.0-cgi alone:
    #   fastcgi_pass 127.0.0.1:9000;
    #   # With php7.0-fpm:
    #   fastcgi_pass unix:/run/php/php7.0-fpm.sock;
    #}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~ /\.ht {
    #   deny all;
    #}
}


# Virtual Host configuration for example.com
#
# You can move that to a different file under sites-available/ and symlink that
# to sites-enabled/ to enable it.
#
#server {
#   listen 80;
#   listen [::]:80;
#
#   server_name example.com;
#
#   root /var/www/example.com;
#   index index.html;
#
#   location / {
#       try_files $uri $uri/ =404;
#   }
#}

What exactly am I doing wrong? What should I include in the server block file?

1 Answer

I might be wrong, but it looks like the root that you have:

root /var/www/html;

is not pointing to your sub domain directory.

Have another answer? Share your knowledge.