Question

(d-logind) process consumes 100% CPU

Posted May 5, 2021 129 views
Ubuntu 20.04

On a droplet with Ubuntu 20.04.2 LTS there’s a “(d-logind)” process in “top” which is consuming 100% CPU all the time.
What is this process, and what causes this CPU usage?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @rwaple41,

This process is related to systemd-logind. This is a system service that manages user logins. It is responsible for: Keeping track of users and sessions, their processes and their idle state.

Which makes your issue all the weirder. Having said that, I tried to troubleshoot it a bit. I couldn’t find anything specific without knowing the exact issue. As such, I’ll recommend checking your journal log to see the exact errors that are being experienced:

journalctl -xe

From there we can see what further needs to be done.

Regards,
KFSys

  • A little more info: the system has several thousand bind mounts of the same source directory.
    The issue does seem to be related to this, because it happens when the mounts are mounted.
    I tried running strace on the systemd-logind PID, and it looks like it’s doing something with the files from the mounted dirs, but I’m not sure how to interpret this.
    Also, it looks like after some time, the process restarts, and starts doing the same thing again.

    For the moment I just disabled systemd-logind with “systemctl mask systemd-logind.service”, and the issue seems to be gone.
    But I am not sure if there are any implications from this.
    The system is accessed only by the root user via ssh. There are no other logins.