Question

DBeaver SSH connect with DigitalOcean/MySql

After trying every solution that I could find, nothing worked. So I’m posting my question here.

Followed instructions on how to connect but always getting same error

Can't initialize tunnel
  Cannot establish tunnel
    com.jcraft.jsch.JSchException: Auth fail

My connection settings: Server Host: 127.0.0.1 Port: 3306 Username: database username Password: database password

Network: Host/IP: myIPaddress Port: 22 User Name: hostname Authentification Method: Public Key Private Key: ….ssh\id_rsa

What am I doing wrong here?


Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

So, that was stupid of me.

It should be my IP address insted of 127.0.0.1.

Now it works like a charm.

On command I’m getting telnet myipaddress 22

Trying myipaddress ...
Connected to myipaddress.
Escape character is '^]'.
SSH-2.0-OpenSSH_7.2p2 Ubuntu-4ubuntu2.1
Connection closed by foreign host.

Does that have somenting to do with not connesting?

And now I’m getting

Communications link failure

The last packet sent successfully to the server was 0 miliseconds ago. The driver has not received any packets from server.

bind-address is my IP address, tried comment it out, still not working.

Can’t find 50-server.cnf just /etc/mysql/mysql.conf.d/mysqld.cnf

Not quite sure what I need to modify in here?

I’m using hostname for network connection (SSH Tunnel), for connection setting username.