Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

Hi,
I have followed this tutorial and I am having trouble getting SSL to work.
Normal HTTP works fine, but when I try to use HTTPS I get an ERR_ADDRESS_UNREACHABLE error, or via curl: curl: (7) Failed to connect to mydomain.com port 443: No route to host. The HTTPS requests don’t even come up /var/log/nginx/access.log .
Here are the relevant files:
# /etc/nginx/sites-available/mydomain.com
server {
listen 80;
listen [::]:80;
root /var/www/mydomain.com/html;
index index.html;
server_name mydomain.com www.mydomain.com;
location / {
root /var/www/mydomain.com/html;
try_files $uri $uri/ =404;
}
listen [::]:443 ssl ipv6only=on; # managed by Certbot
listen 443 ssl; # managed by Certbot
ssl_certificate /etc/letsencrypt/live/mydomain.com/fullchain.pem; # managed by Certbot
ssl_certificate_key /etc/letsencrypt/live/mydomain.com/privkey.pem; # managed by Certbot
include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot
}
# /var/www/mydomain.com/html/index.html
<html>
<head>
testing
</head>
</html>
My firewall (ufw) is inactive, port 443 is forwarded on my router, nginx -t runs fine. Here are my dns (GoDaddy) records. Both point to my ip.
I’m running Debian 9.6 (stretch) and Nginx 1.10.3.
Edward Sitarski
1fd6b9d2a2b94ee4b3e8ee6d5e2587
Traceurity
fadecomic
Mollie Semmes
Will Walters
f4df2e98b9c74f7eb7f6a0629cf1c4
erel
fingers
fingers