Deploy Rails app to digitalocean using caprover

Posted April 21, 2021 696 views
Ruby on RailsDigitalOcean Droplets

I’m trying to deploy my Rails 5 app to digital ocean using CapRover. The problem is when some gems require some other packages to be installed, like ovirt-engine-sdk, that needs xml2-devel. When I run:

caprover deploy

It raises the next error:

extconf.rb:29:in `<main>': The "libxml2" package isn't available. (RuntimeError)

I’ve tried to install them manually from the digital ocean console, but it doesn’t work. Investigating a little I found that I might need to use a Dockerfile instead.

How can I deploy my project and indicate the dependency libraries needed for the gem packages?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Hi there,

There was a similar issue raised on the official GitHub repository here:

People are suggesting defining a captain-definition file and adding the install command in there.

For more information on how to do that, you could take a look at the following page:

Let me know how it goes!