Question

Domain name SSL wordpress droplet

Posted November 12, 2021 100 views
WordPressDNSLet's Encrypt

Hello,

I have been struggling for the past 2 days to fix this problem. I have read countless forum answers (DO and others) and I can’t figure it out.

TLDR: I can’t use my domain name (stairway.ma) in my DigitalOcean Wordpress droplet.

  • Domain name provider: Capconnect.com (I need a .ma domain)DNS settings 1, DNS settings 2 (idk why it has 2 settings btw).
  • DigitalOcean droplet: Ubuntu WordPress 5.8 on Ubuntu 20.04 (IP: 64.227.33.133)
  • DigitalOcean DNS records.
  • DNS checker points stairway.ma to the right IP.
  • DigitalOcean SSL pointing to domain name stairway.ma

  • When works both URLs point to 64.227.33.133, it works.

  • When I change both URLs to http://stairway.ma, it says the site is not secure, and only http://stairway.ma works (and not www.stairway.ma)

  • when I change the URL to https://stairway.ma, nothing works, the whole website is down.

I’ve probably created and destroyed a dozen droplets since yesterday:

  • During the wordpress console installation, I tried adding ‘stairway.ma’ as a domain name and add SSL, but it won’t work, it says there’s some firewall problem and I can’t access the website.
  • I tried disabling the firewalls in another installation but it still won’t work.
  • I tried starting a new droplet and using the droplet’s IP as the domain name, it worked, but when I try changing the domain to stairway.ma, the whole thing goes down.
  • I tried adding this to wp-config: define('WP_SITEURL', 'http://stairway.ma'); define('WP_HOME', 'http://stairway.ma'); but it doesn’t work.
  • I tried another wp-config edit with https://stairway.ma, but it won’t work.

Any ideas?
I would appreciate any help and thank you in advance for your time.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

UPDATE: I found the solution, it wasn’t a firewall problem.

Forget the wordpress SSL plugins, just follow this tutorial but instead of editing

/etc/apache2/sites-available/your_domain.com.conf

edit

/etc/apache2/sites-enabled/your_domain.com.conf

I did step 2 via FTP, not console.

I hope it helps others, good luck.

by Kathleen Juell
by Erika Heidi
Let's Encrypt is a Certificate Authority (CA) that provides an easy way to obtain and install free TLS/SSL certificates, thereby enabling encrypted HTTPS on web servers. In this tutorial, you will use Certbot to obtain a free SSL certificate for Apache on Ubuntu 18.04 and set up your certificate to renew automatically.

Hey there!

From what you have provided here it looks like your DNS settings are all correct. It looks like the SSL isn’t being installed which would need to be setup before you can change the sites URL. What errors are you seeing when trying to setup the SSL for the domain through SSH during setup?

Nate