Question

Domain not working without :8000 on dev

Hello,

My domain http://www.superlists-staging.xyz:8000/ is working but http://www.superlists-staging.xyz/ not working and having - HTTP ERROR 404.

The Django dev server is running at 0.0.0.0:8000.

Appreciate anyone can help.

Regards


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

@ryanpq

I am using /virtualenv/bin/python manage.py runserver 0.0.0.0:8000 for now for the test purpose. I log to my droplet using ssh from my mac. I did not setup any web server. I have amended the Django settings.py as shown below:

SECURITY WARNING: don’t run with debug turned on in production!

DEBUG = True

ALLOWED_HOSTS = [‘*’]

Let me know if you need more info.

Regards

This issue has been solved.

@ryanpq

Thanks for the response. Since I am at work right now I will update this thread as soon as I get hold of my Mac at home.

Regards

It would appear that while you’re able to access your Django instance directly on port 8000 your web server is not configured properly to proxy those connections when you are trying to access it via port 80 (the default).

Which web server are you using? Nginx or Apache?

If you can share your site configuration (/etc/nginx/sites-enabled or /etc/apache2/sites-enabled) we can likely help you make the adjustments needed to access your site on the default http port.

Once that is working you’ll likely want to change your Django setup to listen on 127.0.0.1:8000 or localhost:8000 (this way it would only be accessible through the web proxy and would no longer appear on port 8000 publicly.