Question

droplet ipv6 PTR

Hi. I’m in my droplet enabled IPV6. It’s work perfect, but i need to set PTR record for IPV6 address, how i can do that? With IPv4 address PTR record work correctly and for IPv6 i don’t get resolve


Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

alexdo
Site Moderator
Site Moderator badge
December 7, 2020
Accepted Answer

Hello, all

The support for PTR records for IPv6 addresses was actually added a while back. By default, the each Droplet with IPv6 enabled will be configured with a single IPv6 address. This is the address that will be used for any PTR records that will be generated for domains pointing at your server. Like with IPv4, if the hostname given to the Droplet is a FQDN, the PTR record will be generated automatically.

If you’re looking for more control over PTR records more generally, there is an open request for allowing users to manually set PTR records. Please vote for it on UserVoice if that’s something you’d like to see:

https://digitalocean.uservoice.com/forums/136585-digitalocean/suggestions/4108036-allow-ptr-records-to-be-set-separately-from-the-ho

Hope that this helps! Regards, Alex

To set the PTR for the IPv6 address:

All you need to do is temporarily change the name (Domain) of your droplet to something other than what it was set to when you enabled IPv6.

Then wait 1 minute, and change it back to the Domain Name you originally set it to before adding IPv6.

For example:

My domain was set to ser1.example.com. I enabled IPv6. I would change the domain to temp.example.com. Wait 1 minute. Then Change the domain back to ser1.example.com.

I hope that this finally resolves your issue.

Sincerely, Adam