Question

error configuring WebSocket listener conf / config.xml with PuTTY

Greetings community, I am trying to configure WebSocket listener, with PuTTY, everything is fine when copying and saving in conf / config.xml, but when restarting the server, I do not get a favorable response. I am also getting this error.

ERROR - Could not read the configuration file /opt/hivemq/conf/config.xml. Using default config


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @wjimenezb7,

Usually, that error is generated when there is a typo somewhere in the config file. I’ve searched the Hivemq community for similar issues and it seems like every time this error is mentioned, it’s a typo or some kind of misconfiguration in the configuration file you mentioned:

 /opt/hivemq/conf/config.xml

You have two options now. To paste the configuration file here and we to try and help you out without being experts on it.

The second one would be to check the Hivemq community about such a problem.

I would start with the first option and we are not able to help out go with the second one.

Regards, KFSys