error duplicate listen options for [::]:443 when trying to add a subdomain to my nginx setup

I followed [this DigitalOcean guide on how to setup Nginx] ( an Ubuntu 18.04 droplet. I set up my domain’s nameservers to point to Cloudflare’s and then based on what I had read previously my understanding that to add a subdomain ( in this case) I could simply add a file titled ( to the /etc/nginx/sites-available (and symlink that file with /etc/nginx/sites-enabled) Keep in mind I am using Let’s Encrypt

However when I add that file and then try to enable that site, I get the following when running sudo nginx -t

nginx: configuration file /etc/nginx/nginx.conf test failed```

Now the config was created by copying the config and modifying it slightly. With the blog subdomain not included in ``sites-enabled`` nginx produced no errors in the configs.
I have tried the same procedure to create the config for the subdomain twice, no luck. I have shown the below files to a buncha people who then suggested I try a couple different things like removing the ``default`` config from ``sites-enabled``, no luck.
So can anyone please help with this issue?
Also before I forget I intend to deploy Ghost on that blog subdomain

My nginx.conf, config, default config, and configs are attached in the pastebin links below.

[ config](
[default config](
[ config](

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Ok so I looked at this guide and found this:

In this new file, we’re going to have to look at the listen directives again. If you left the default_server option enabled in the last file, you’ll have to remove it in this file. Furthermore, you’ll have to get rid of the ipv6only=on option, as it can only be specified once per address/port combination:```
So I removed the line in the config that contained the ``ipv6only=on`` option.

And it works now.

Please leave this up in case anyone else comes across this issue.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel