I am using php to send emails from my droplet and the emails always go to the gmail spam folder.

Specifically, I see the following:

Received-SPF: pass (google.com: best guess record for domain of www-data@droplet.onlineschoolrecords.com designates 162.243.172.35 as permitted sender) client-ip=162.243.172.35;
Authentication-Results: mx.google.com;
spf=pass (google.com: best guess record for domain of www-data@droplet.onlineschoolrecords.com designates 162.243.172.35 as permitted sender) smtp.mailfrom=www-data@droplet.onlineschoolrecords.com

Something needs to be done in order to avoid having the emails go to the spam folder.

The message “best guess record for domain” indicates that something needs to be done with the subdomain “droplet”?

Do I have to define something in the DNS?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

It appears that you have an SPF record configured for onlineschoolrecords.com, but not droplet.onlineschoolrecords.com, which emails are being sent from. This is why you are seeing that message—Google is guessing that it should use your domain’s SPF record for the subdomain as well.

Consider using DKIM in order to try and improve deliverability rates. See this tutorial—it is a bit old, but the instructions should still work.

You can also use this tool to check your server’s settings and see if you can improve anything else: https://www.mail-tester.com

by Popute Sebastian Armin
This tutorial will focus on installing and configuring OpenDKIM: an open source implementation of the DKIM sender authentication system.
Submit an Answer