Question

Graphs panel is not showing anything. Last working 2 days ago.

I upgraded metric agents long ago. it was showing me graphs(CPU,memory,bandwidth…) until few days ago. Now graphs page shows nothing. it’s just empty. I tried another browser still no graph. I created new droplet(ubuntu) with monitoring enabled, still no data no graph. Why did monitoring suddenly disappear from all my droplets even though I made zero change.

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

My adblocker was blocking it. Fixed by turning it off. Weird things is my other browsers’ adblockers were also blocking it. They weren’t blocking before.

Can confirm that the graphs are being blocked by PiHole. Adding cdn.optimizely.com to your whitelist should fix the problem.

I’m having the same issue. I think the issue is more than just an ad blocker as I don’t have installed, only host based blocking using PiHole.

Possible domains are: cdn.siftscience.com and cdn.optimizely.net. Both are blocked due to tracking reasons I believe.

For anyone who hasn’t installed the metrics monitoring with the droplet, try this page: [https://www.digitalocean.com/docs/monitoring/quickstart/]

“Once the metrics agent is enabled and has gathered enough data, the Graphs section of your Droplet’s detail page displays extended metrics and new graphs.”

Seeing the same problem now, all the graphs of my Droplets are empty, please look into this ASAP DigitalOcean support!