Hello script running with no pm2 scripts enabled

Posted May 19, 2021 198 views
NginxDigitalOcean Droplets

My droplet was working fine, but my payment was overdue so it got suspended. I payed everything off and server is running again. My data got preserved and nothing has changed.

But this time it is stuck on initial hello script saying “Sammy welcomes you to your Droplet!” There is no pm2 scripts running, the hello script is deleted.
My nuxt application is showing: Error: Address `` is already in use. so there is something running. I tried killing pm2, restarting everything from droplet to pm2 and
I spent multiple hours trying get this to work.

When I run pm2 list - it’s empty.
When I run pm2 start npm -- start it says online but it keeps restarting every few seconds.
When I run pm2 show hello it says: [PM2][WARN] hello doesn't exist

I tried reinstalling pm2, killing it, cleaning cache, restarting nginx, droplet and more…

How can I get rid of this hello script and free my 3000 port so I can run my app? Thanks.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

Fixed by deleting .pm2 folder from my droplet.

I had a similar problem, though the hello.js script still existed as a file on the server. The hello script was submitted by the nodejs-user, so to make any pm2 commands I had to write sudo -u nodejs list, sudo -u nodejs restart hello and so on.