High CPU usage every day after update new droplet

Posted January 24, 2018 13.4k views

Hi , i update the droplet to new Digital Ocean. I was 512 ram . Now 1Gb , After upgrade all the day in the same time i got High CPU usage.
Can u tell me how to check who proces is consuming this?
Thank you!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
18 answers

I’m experiencing exactly the same problem. I have noticed that CPU activity increased considerably after resizing my Droplet (to take advantage of the benefits their new plans).

Recently I opened a ticket to follow up on this situation (so far, they have followed my report.. but there has not been a solution).

In fact.. researching a bit, I found this tweet (so I deduce that I’m not the only one who has this reduction in performance):

My tests:
Just before resizing my Droplet, I took a Snapshot from this one.

As a test, I created a new Droplet from that image in same datacenter -SFO2- (I was assigned a new public IP). Once created, I subjected it to an equal load of intensive to the usual and runs perfectly (it was not perceived excessive CPU load).

Once that I proved that my Snapshot worked well and stably, I decided rebuilt my main Droplet (which presents the problem) expecting it to work fine, but I still have the same problem having an excessive CPU load.

As an additional detail, I have noticed that Droplet’s boot takes too long whitout apparent reason (60 secs aproxly, when it regularly was loading in 15 secs at most).

A very practical solution for me would be to create a new Droplet from my Snapshot. The drawback is that I need to keep my public IP assigned initially.


  • Sry my english isnt very good!
    You said if
    1- i made a snapshoot create a new droplet and restore in new have this problem fix?
    2- I made new droplet put all my programs manually and this is working fine ?

    Thx - Gracias

    • Hi,
      Don’t worry. My english is worse (aunque si lo prefieres, mejor en español).

      Well … before changing the size of my droplet (when it still works perfectly), I took a snapshot of this. Once I detected a high CPU usage for no apparent reason, in parallel I created a new Droplet from the snapshot. It worked without problems.

      So… I rebuilt my main droplet from that snaptshot, but it still presents the same problem of high CPU consumption (even when I deactivated the services that could be generating the excessive load).


      • Gracias Ivan , cree un ticket a Digital Ocean , veo que desde que Upgrade el droplet me anda muy mal y me llegan alertas de HIGH CPU y MEMORIA ( cuando ahora tengo mas supuestamente).
        Voy a ir actualizando esto a medida que conteste DO.
        @Podias indicarme que servicios desabilitar ? para saber si puedo mejorar un poco el rendimiento?
        Muchas Gracias


        • Hola de nuevo,
          En mi caso, deshabilité todos los servicios que instalé en un principio: httpd, postfix, dovecot, mariadb, y spamassassin (aunque antes de redimensionar mi Droplet, todos habilitados representaban una carga aproximada de 30% de CPU).

          De igual manera, hace 3 días levanté un ticket al área de soporte de DO y me recomendaron revisar mis ajustes del sistema para tratar de detectar algún comportamiento inusual, pero no es el caso.

          En mi respuesta inicial, hice referencia a un tuit que me pareció peculiar:

          También respondí ese hilo y adjunté una imagen del monitoreo de mis recursos a través del panel de administración de DO.

          ¿Por cierto, en qué datacenter tienes tu Droplet?


          —- Translate by Google —
          Hello again,
          In my case, I disabled all the services I installed at the beginning: httpd, postfix, dovecot, mariadb, and spamassassin (although before resizing my Droplet, all enabled represented an approximate load of 30% of CPU).

          Similarly, 3 days ago I raised a ticket to the DO support area and they recommended me to check my system settings to try to detect some unusual behavior, but that is not the case.

          In my initial response, I referred to a tweet that seemed peculiar to me:

          I also answered that thread and attached an image of the monitoring of my resources through the DO administration panel.

          By the way, in what data center do you have your Droplet?

You should use the top command in your console. It should give you a reading of what processes are using the CPU a lot.

Hi techkat , i know if i see the top i can se the process , I question about how to see if have some log or some i can see the past porcess.
Example now is 7:00 am i need to view what proces consuming CPU 3:00 am

I am also seeing this… Looking forward to a resolution…

Same for me, my Mysql goes to 100% after upgrade, i have 2 different droplets with same behavior after upgrade.

As of April 6th I am also experiencing this (pretty severe) problem in NYC1. My CPU graph looks very similar to Arajdon’s tweet referenced above. I resized with the memory/cpu only option and not disk space. There must be a bug somewhere in the implementation.

Same here, The difference between pre-upgrade and upgrade is obvious. I have upgrades for other companies to do but holding off until this get’s resolved.

Appearently having the same problem.

I have the same problem

I have the same problem, anyone from DO reading this?

Previous 1 2 Next