zkarj
By:
zkarj

How can I stop my domain from displaying the IP address?

January 21, 2018 312 views
DNS Apache CentOS

I've read countless questions and answers almost identical to my problem but cannot figure this out. Environment is Apache 2.4.6 on CentOS 7.4.

I have my nameserver records with DO:
A jenks.nz points to my droplet
CNAME www points to jenks.nz

Either of those addresses loads my site. If I use the www prefix, then that domain remains in my browser location bar. If I use the one without www then the location switches to the IP address.

My virtual host config is as follows:

<VirtualHost *:80>
    ServerName jenks.nz
    ServerAlias www.jenks.nz
    DocumentRoot /var/www/jenks.nz/public_html
    ErrorLog /var/log/httpd/jenks.nz.error.log
    CustomLog /var/log/httpd/jenks.nz.requests.log combined
</VirtualHost>

I originally had the ServerName and ServerAlias around the other way but the result was the same.

At this stage I have a simple, static HTML page for testing. There's a WordPress install waiting in the wings, and I know about the settings there (because I've stuffed them up on several occasions before on shared hosts :-) ). I've verified there is no .htaccess file in the document root for this virtual host.

I'm sure I'm missing something simple, but I cannot figure out what.

1 comment
  • How odd. I just tried it on a different Mac this morning and the domain stays put in both variants. Is the original Mac (Safari) caching the 'name' somewhere?

1 Answer
zkarj January 21, 2018
Accepted Answer

Solved! The issue was Safari (macOS) caching the DNS entry from prior to the config changes.

I flushed the DNS cache with the following command on macOS 10.13 High Sierra (should also work on 10.12 Sierra).

sudo killall -HUP mDNSResponder

Have another answer? Share your knowledge.