How to configure gunicorn (and make sense out of it)

I have cloned my git repo in :here


then I have created a gunicorn_start file inside: directoriovirtual

the gunicorn_start file reads:

NAME=“django_videos” DIR=/var/www/directoriovirtual/languaget USER=user_videos GROUP=videos WORKERS=3 BIND=unix:/var/www/run/gunicorn.sock DJANGO_SETTINGS_MODULE=tutoriales.settings DJANGO_WSGI_MODULE=tutoriales.wsgi LOG_LEVEL=error

cd $DIR source …/directoriovirtual/bin/activate


exec …/directoriovirtual/bin/gunicorn ${DJANGO_WSGI_MODULE}:application
–name $NAME
–workers $WORKERS

I have tried to test whether it works but very unsure of what I am doing:

sudo systemctl status gunicorn

and the dreaded answer goes:

Unit gunicorn.service could not be found.

The domain shows nginx is working, now I was trying to add gunicorn and then supervisor but kind of lost at this point.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer


It is solved.

Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Featured on Community

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel