Question

How to ssh with i flag

Posted December 30, 2017 4k views
CentOSConfiguration Management

I just finished the tutorial for setting up CentOS on my droplet. Everything works except when I ssh into as a non-root user I have to point to my private key like so ssh user@ip -i ~/.ssh/id_user_rsa or else I get this error: Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

My first question is: is this normal?

Second, by the end of the article, ssh access to root is disabled. I used 2 different ssh key pairs for root and my other user. Does this mean I can delete the ssh key pair for root? Is it good practice to have 2 pairs like this?

1 comment

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer
Submit an Answer