I cant access my website I always get redirected to rrot

Posted March 23, 2020 631 views

Hi I need help, i just installed certbot after that im unable to access my website i always get redirected to root, please help i tried removing cerbot but still the same issue

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
1 answer

Hi @Xunne,

It seems you have redirection in place. Depending on the WebService you are using - Apache/Nginx this can be in a different place. We’ll review both situation

  • Nginx

Firstly, you’ll need to learn how block learn in Nginx. There is a really good tutorial from DigitalOcean here -

Once you know where and what blocks are used for you can check the Let’s Encrypt installation with Nginx

It will show you how to secure it.

Now onto the problem itself. Check the Nginx configuration for your website/application and see if there are multiple redirections placed. If there are multiple ones, you’ll need to remove at least one.

  • Apache

Now, Apache doesn’t have blocks but there are vhosts. If you are unsure how to configure them, you can check how here, again a tutorial by DigitalOcean

Once you now how to configure Vhosts, you can see how to configure Let’s Encrypt by reviewing the following article :

Now, Apache can have two places where the problem may be experienced. The first one would be your vhost file, you can have some redirection rules there.

The second place is your website’s .htaccess file. Check if there are any redirection to https.

  • Website

The last place you should look would be your website and see if there is any redirections set there.

Now, we won’t be able to help with the website however if you are unsure, you can post the configuration file of your WebService and we’ll try to help out.


by Justin Ellingwood
When using the Nginx web server, server blocks (similar to the virtual hosts in Apache) can be used to encapsulate configuration details and host more than one domain off of a single server. In this guide, we'll discuss how to configure server blocks in Nginx on an Ubuntu 16.04 server.
  • Hello thank you for the reply, I am using apache, i have tried the things that you have provided me, I actually also removed cloud fire redid certbot, but still the same i also tried making my own conf but still the same issue, i was able to go to my home page with https but i wasn’t able to go to wp-admin it still routs me to root i did try to check cers after removing all the ssl but it still showing that i have them, i tried loking into how to remove them and i did but still the same issue. pls help im realy on the last leg here and i don’t know what to do

    • Hi @Xunne,

      Can you post your .htaccess file, it’s possible the issue lies there. Maybe you have a misconfiguration there?


      • hello yea here is whats inside ht access

        BEGIN WordPress

        The directives (lines) between BEGIN WordPress and END WordPress are

        dynamically generated, and should only be modified via WordPress filters.

        Any changes to the directives between these markers will be overwritten.

        <IfModule mod_rewrite.c>
        RewriteEngine On
        RewriteBase /
        RewriteRule ^index.php$ - [L]
        RewriteCond %{REQUESTFILENAME} !-f
        RewriteCond %{REQUEST
        FILENAME} !-d
        RewriteRule . /index.php [L]

        END WordPress

        oh and i tried to redo certbot cer but im getting error now letsencrypt live folder is missing

        • Hi @Xunne,

          The .htaccess file seems to be alright. O

          Then you’ll need to enable PHP error logging. It will show you the exact error and you should be able to act upon it.