Question

I have tried to access the droplet digital console, it displays black screen, when I click on it everything hangs.It's so frustrtaing!

Tried it severally but not working. The only thing I did was to change my password yesterday. Please help. Thanks

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

@stankoech

The web-based console can be finicky depending on the browser you’re using, so it’s often best to use either Terminal on MacOS or PuTTy on Windows 8/10 to SSH in to your server and access the CLI.

The console is, ideally, meant to be used as a last resort when you’re either locked out of your server or have absolutely no better option to login.

As jtittle writes, use the SSH protocol instead of the browser based console. If you need help, then have a look at this tutorial - otherwise just ask and we’ll try to help: https://www.digitalocean.com/community/tutorials/how-to-connect-to-your-droplet-with-ssh

Hello, @jmkhabela

Next time this happens, you can try typing CTRL+C and see if this helps.

Hope this helps.

Regards, Alex

I powered off then, powered on the droplet, which work perfectly.