mikebio
By:
mikebio

I installed Wordpress with Easy Engine and I am receiving an error that Wordpress cannot connect to Wordpress.org

March 21, 2017 881 views
Nginx Ubuntu 16.04

I also have LetsEncrypt installed. Here is the full error:

FastCGI sent in stderr: "PHP message: PHP Warning: An unexpected error occurred. Something may be wrong with WordPress.org or this server configuration.
WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator.

Everything was working fine up until a few hours ago. I tried to search online for a solution but couldn't find one.

This error is preventing me from downloading and installing plugins.

Any suggestions?

Mike

3 Answers
hansen March 21, 2017
Accepted Answer

You're probably hit by the latest security update from Ubuntu, which messed up some certificates, which PHP uses to make the secure connection.
https://www.ubuntu.com/usn/usn-3239-1/

Run this service php7.0-fpm restart and it should fix it. Or simply restart your server.
People running Apache, needs to restart that with service apache restart

  • Thank you so much. Honestly, that was a huge help and it worked immediately.

    Seriously... thank you!

I have the same problem as Mike. "WordPress could not establish a secure connection to WordPress.org. Please contact your server administrator." I cannot update plugins or download themes.

Also, in the Wordpress News section on the WP dashboard I get this error "RSS Error: WP HTTP Error: User has blocked requests through HTTP."

I have installed Wordpress on a 512mb digital ocean droplet using Serverpilot. Lets encrypt certificate is installed.

Please help.

Thanks,
Ananth

  • I ran these commands to restart services
    sudo service nginx-sp restart , sudo service apache-sp restart
    and sudo service php7.0-fpm-sp restart. But no luck.

    • Hi ananth,

      I just got this problem today and I fixed it by

      sudo systemctl restart php-fpm.service
      
      sudo systemctl restart php-fastcgi.service
      
      sudo systemctl restart nginx.service
      

      Reloading my wordpress site and it worked!

Have another answer? Share your knowledge.