I've tried to run Nginx Ruby On Rails Ubuntu 16:04. I'm facing the same issue with both solution I tried.

I follow steps from the blog. Some steps cause me lot of troubles. So move to One-click Install Ruby On rails droplet. It works with the default project. But I want to run my project, using the sites-enabled conf.

All file are uploaded to : 1- /var/www/metribook/epicure-app 2- in /etc/nginx/sites-enabled I changed the default site config to the one in 1) 3- I got the same error when I restart nginx service with sudo: sudo service nginx restart error: Job for nginx.service failed because the control process exited with error code. See “systemctl status nginx.service” and “journalctl -xe” for details.

I got the same error with the first Droplet. I already install Nginx with Passenger many times on EC2 but I cannot resolve this issue. Need some help.

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Most likely you forgot to add a ; usually after the listen directive and declaring it on port 80.

Additionally, we have also launched an app platform where we provided a managed Ruby on Rails solution where you can just push your code to Github and have it deployed automatically so you don’t need to install and manage Rails yourself anymore unless you want to.

You can find out more information about our app platform here: