rshpeley
By:
rshpeley

Install and configure wordpress on lemp on ubuntu 16.04 with wordpress in subdirectory

March 5, 2017 181 views
WordPress LEMP Ubuntu 16.04

This question has been asked a lot and so far solutions have only been posted for LAMP. How about we get an answer for this and put it into a tutorial?

The root of the website should be static or php without wordpress installed in it. Call it mywebsite.

A subdirectory, let's say blog, has wordpress installed in it => https://mywebsite/blog will access the blog.

This is to be done with one DO instance and managed by nginx server blocks, I presume.

The problem I've had is that the wordpress admin panel doesn't respect https://mywebsite/blog (by checking the page source of the admin panel) and attempts to load external files by https://mywebsite.

Is this a wordpress problem or a configuration problem?

2 Answers
hansen March 5, 2017
Accepted Answer

Did you install WordPress in that location originally?
If not, then you need to adjust your URL in the configuration at https://mywebsite/blog/wp-admin/options-general.php so it includes the /blog/ part
There might be some stuff still left in the database, but we can search/replace that once the other part is done.

  • Yes, I originally installed wordpress into the website root. How would you suggest I adjust the URL configuration? The options-general configuration won't run directly in the browser.

    Maybe the database value for WordPress URL needs to be updated? Or should I do a new multisite install after clearing the database?

    • You can go and edit the database directly, in the table wp_options find option_name called siteurl and home and modify to the correct path.

I've edited the database and now I can display the blog page, but I can't login with wp-admin. It refuses my username and password. When I attempt to recover the password it doesn't recognise my email address.

  • Well, it sounds like the installation has been messed up. It is possible to manually go through the entire database and correct everything, but it might be much easier simply to reinstall WordPress (and tables in database) in the location where you want it.

    • The reinstall did it... just another droplet.

      So the moral of the story is to install wordpress directly into the subdirectory you want it in the first time.

      Thanks @hansen!

Have another answer? Share your knowledge.