Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

I’m using the DigitalOcean Kubernetes and trying to deploy tiddlywiki with a volume (https://www.digitalocean.com/docs/kubernetes/how-to/add-volumes/). I’ve got the following PVC definition:
apiVersion: v1
kind: PersistentVolumeClaim
metadata:
name: tiddlywiki-pvc
spec:
accessModes:
- ReadWriteOnce
resources:
requests:
storage: 1Gi
storageClassName: do-block-storage
but the volume is not created. kubectl describe pvc tiddlywiki-pvc outputs:
Events:
Type Reason Age From Message
---- ------ ---- ---- -------
Normal Provisioning 5m24s (x7 over 21m) dobs.csi.digitalocean.com_master-k8s-1-13-2-do-1-fra1-1550947912278_82be847f-379c-11e9-b070-c26e25b214e8 External provisioner is provisioning volume for claim "default/tiddlywiki-pvc"
Warning ProvisioningFailed 5m24s (x7 over 21m) dobs.csi.digitalocean.com_master-k8s-1-13-2-do-1-fra1-1550947912278_82be847f-379c-11e9-b070-c26e25b214e8 failed to provision volume with StorageClass "do-block-storage": rpc error: code = Internal desc = GET https://api.digitalocean.com/v2/volumes?name=pvc-062c18f0-41e7-11e9-9fb2-c26e25b214e8®ion=fra1: 401 Unable to authenticate you
Normal ExternalProvisioning 70s (x82 over 21m) persistentvolume-controller waiting for a volume to be created, either by external provisioner "dobs.csi.digitalocean.com" or manually created by system administrator
The 401 Unable to authenticate you could indicate that the API token isn’t present/expired, but I was able to create a PVC a few weeks ago on the same k8s cluster. Did anyone have a similar problem? Am I missing something or could it be a bug?
72e571841e7f4a6881090a2f3e93c0
1txm05v1txm05v
jazzybruno
jazzybruno
1c73a43cf7ab4e9cb7f9e551f34a5e
Server Enthusiast
Sean DesPortes
Robin van der Knaap
4a0d624689d3431099e1b568c03569
Tomy Hsieh
Marek
BIdhan Bastola