Question

Magento 2.3.x Admin panel keeps loading (fresh installation)

Hi, I have been trying to install Magento 2.3.5-p1 on Centos 7, Nginx with Php-fpm and maria db. I was able to install it after fixing several issues and Home Page is perfectly okay now. But my admin panel keeps on loading with a loader gif (i suppose). I get several file error i.e. either Refused to Load, or 404, one file is being Refused to load on both frontend and admin panel i.e. requirejs-config.js.

At First, I tried installation user:nginx, i.e. my user is associated to nginx group. RESULT: Admin panel keeps loading. Then, I installed it by adding user to group php-fpm. RESULT: Admin panel still keeps laoding…

I have tried almost all the available answers I could find in past 2-3 days on google, but nothing works for me.

I tried:

1) Change Symlink to Copy in /di.xml
2) Reinstall several times 
3) c:c / c:f
4) Deleting all the data in static/, var, and then deploying again
5) Changing permissions, used 777/755/077/g+w/g+ws
6) bin/magento setup:static-content:deploy -f
7) php bin/magento indexer:reindex
8) disabled magento_csp on (2.3.5-p1)... 
9) di:compile, upgrade followed by deploy
10) I cant remember, but I must have used other ways
11) Install Magento 2.3.4-p2 instead

Screenshot

bin/magento setup:install --base-url=https://www.example.com/ \
--base-url-secure=https://www.example.com/ \
--db-host=localhost --db-name= --db-user= \
--db-password='' --admin-firstname= \
--admin-lastname=Admin --admin-email= \
--admin-user=admin --admin-password= --language=en_US \
--currency=USD --timezone=UTC --use-rewrites=1

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

I have solved it, it was due to open_basedir, once i disabled it in php.ini and restarted php-fpm, and reinstalled magento, it worked fine.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.