Question

Managed Database Cluster is full and it's on Read-only mode

Hi, I would like to know what I can do to free up space in a full database, I can’t do anything because it has been put in read only mode. Thank you


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hi there,

I just noticed a similar question asked here with a very good answer:

https://www.digitalocean.com/community/questions/how-to-disable-read-only-mode-when-managed-database-storage-is-full

The answer suggests the following:

To remove your database from the read-only mode you will need to do one of the below two options:

  • Upgrade to a larger plan from the DigitalOcean Console
  • Delete data from your database by changing the transaction mode to read-write for your session by executing:
SET default_transaction_read_only = OFF;

This will enable you to delete data from within your current session.

Hope that this helps!

Regards, Bobby