Question

NextJS Web Service Images Don't Load

Posted March 31, 2021 1.2k views
ReactDigitalOcean App PlatformNext.js

I am currently attempting to use the built-in NextJS image optimization while hosting on the DO App Platform. Everything seems to be working, but when I try to load pages, the images either load slowly, or don’t load at all. Has anybody dealt with this?

Repo
Live

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hey @forrestblackburnkeller sorry for the delay. I hope you were able to figure this out. This answer is from one of our developer advocates who is more familiar with Next.js than me:

Hey your code looks good to me. It looks like you’re pulling in images from an external url. It could be that graphcms is giving errors or being slow on some calls?
Try downloading an image and using <NextImage /> with it locally to see if that improves the situation.

Hi, I am facing the same problem. My site works fine with vercel server. I would like to host my site on Digital ocean. Therefore I started testing and found images are too slow to load. Sometimes it takes 10sec to load 9 images.

https://adbwien-6hwrd.ondigitalocean.app/blog hosted on digital ocean

https://adbwien-cszpgqg9g-princesodhi.vercel.app/blog hosted on vercel

After spending the couple of hours. I am thinking to go for another service.

Note: I have my all images in the public/static folder.