Nginx Server Blocks don't work with droplet created with on-click apps

February 22, 2018 690 views
PHP WordPress LEMP Ubuntu 16.04

hello every one
no I create a new droplet with on-click apps (Ubuntu 16 lemp )
and I have two domain from godaddy and I point to this domains to my dorplet
and I follow this tutorial to make my droplet Server Blocks
https://www.digitalocean.com/community/tutorials/how-to-set-up-nginx-server-blocks-virtual-hosts-on-ubuntu-16-04#prerequisites
and try deploy to sits wordpress
with this domains
http://alyahyamb.com/
http://muthaberapp.com

the problem is : first domain work fine but when I connect to second domain (http://muthaberapp.com) redirect to me to the first one (http://alyahyamb.com/)

note : I created sub-domain for each domains and it's work fine with api project
I don't understand what happen

I need help

2 Answers
ryanpq MOD February 22, 2018
Accepted Answer

If you can share your current nginx configuration files in /etc/nginx/sites-enabled we'd be happy to help spot and resolve the problem. Without knowing what is in your configuration it is difficult to pinpoint the case of the problem you're experiencing.

  • first nginx cofigure for first domain

    server {
        listen 80;
        listen [::]:80;
    
        root /var/www/bekarywp/html;
        index index.php index.html index.htm index.nginx-debian.html;
    
        # Make site accessible from http://localhost/
        server_name alyahyamb.com www.alyahyamb.com;
    
        location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
            try_files $uri $uri/  /index.php?$args;
            # Uncomment to enable naxsi on this location
            # include /etc/nginx/naxsi.rules
        }
    
        error_page 404 /404.html;
        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
            root /usr/share/nginx/html;
        }
    
            location ~ \.php$ {
            include snippets/fastcgi-php.conf;
            fastcgi_pass unix:/run/php/php7.0-fpm.sock;
        }
    
        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #   deny all;
        #}
    }
    

    and this for second domain

    
    server {
        listen 80;
        listen [::]:80;
    
        root /var/www/muthaberwp/html;
        index index.php index.html index.htm index.nginx-debian.html;
    
        # Make site accessible from http://localhost/
        server_name muthaberapp.com www.muthaberapp.com;
    
        location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
            try_files $uri $uri/ /index.php?$query_string;
            # Uncomment to enable naxsi on this location
            # include /etc/nginx/naxsi.rules
        }
    
        error_page 404 /404.html;
        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
            root /usr/share/nginx/html;
        }
              location ~ /fpm/status/(.*) {
            include fastcgi_params;
            fastcgi_param  SCRIPT_NAME  /status;
            fastcgi_pass $1;
            }
              location ~ \.php$ {
                    root /var/www/html/muthaberwp;
            fastcgi_pass   127.0.0.1:9000;
            fastcgi_index  index.php;
            fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
            include        fastcgi_params;
            }
    
    
        #location ~ \.php$ {
            #include snippets/fastcgi-php.conf;
            #fastcgi_pass unix:/run/php/php7.0-fpm.sock;
        #}
    
        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        #location ~ /\.ht {
        #   deny all;
        #}
    }
    
Have another answer? Share your knowledge.