Nokogiri Gem not working

  • Posted February 19, 2014

I have various gems that I require at the top of a basic ruby script. When I run $ ruby file.rb the gems can’t be loaded.

/usr/local/rvm/rubies/ruby-2.0.0-p353-dev/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in require': cannot load such file -- Nokogiri (LoadError) from /usr/local/rvm/rubies/ruby-2.0.0-p353-dev/lib/ruby/site_ruby/2.0.0/rubygems/core_ext/kernel_require.rb:55:in require’ from etsy.rb:2:in `<main>’


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

It’s a little bit late to answer, but just for the record: I solved this by using RVM installation of ruby and running rvmsudo gem install nokogiri :)

Hi, <br> <br>I had a similar issue I got around it by installing it manually from here. it looks like it hasn’t been installed. Alternatively if you want to check if it was installed or not just run gem install nokogiri