One-Click Wordpress can't export to Ghost

since blogspot have some issue about API limit, Blogger to Ghost is not able to export over 150 posts, So I decide to do a Blogger -> wordpress -> ghost, all things were going smooth, (export to Wordpress/comments/images… etc) but when I run ‘export to Ghost’ at wp-admin, it will export a** 0 byte** js for me to download it. since I’m not a WordPress/Apache guy, I don’t know what is happening,

I’ve done all the googling I can but I can’t find any related threads talk about it.

so if someone know where is the problem it will be awesome. cause wordpress’s droplet is still ticking ;P

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Found solution, Seems like “Export to Ghost” plugin won’t work from time to time, It’s because XML: not well-formed * I think *, if you trying to locate the problem, as @xMudrii said, you will need to download wp2ghost.

once you setting wp2ghost up, you can see from error messages it shows and locate which line is causes the problem.

in my case is an URL have & in it. (e.g. youtube link) simply replace it with & and you are good to go.

This comment has been deleted

    I would check permissions of Wordpress. Login to your droplet via SSH, go to Wordpress directory. Usually it is located at /var/www/html. Execute `

    1. ls -l

    We are using this command to list all files with its permissions, owner and group. Example output would be:

    drwxr-xr-x  2 owner group  4096 Dec 11  2014 wp-admin
    -rw-r--r--  1 owner group 17575 Dec 11  2014 wp-config.php

    First check owner and group. If owner and/or group is root you could have problem. This can be solved by changing owner to regular user e.g. sammy and group to www-data.

    This can be done by following command:

    1. sudo chown -R sammy:www-data /var/www/html

    This will allow Apache applications (e.g. Wordpress and your script/plugin) to read data of Wordpress folders.

    After that try executing your script again. If it’s not problem, we will try to find another root of problem, but this comes first to my mind.

    Try DigitalOcean for free

    Click below to sign up and get $200 of credit to try our products over 60 days!

    Sign up

    Featured on Community

    Get our biweekly newsletter

    Sign up for Infrastructure as a Newsletter.

    Hollie's Hub for Good

    Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

    Become a contributor

    Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

    Welcome to the developer cloud

    DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

    Learn more
    DigitalOcean Cloud Control Panel