Question

Outbound mail (SMTP port 25) seems to be blocked by your network | Mail in a Box

Hi, I have been using Mail in a Box for a while now and it was all working fine but suddenly it stopped working.

I checked the “System Check” section on Mail in a Box’s Admin Panel and it says “Outbound mail (SMTP port 25) seems to be blocked by your network. You will not be able to send any mail. Many residential networks block port 25 to prevent hijacked machines from being able to send spam. A quick connection test to Google’s mail server on port 25 failed.”

Please help.


Submit an answer
Answer a question...

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Simon Bennett
DigitalOcean Employee
DigitalOcean Employee badge
January 24, 2018
Accepted Answer

Your best bet is going to be opening a support ticket.

https://cloudsupport.digitalocean.com/s/createticket

Regards

Simon - SnapShooter

    alexdo
    Site Moderator
    Site Moderator badge
    January 27, 2022

    Hello there,

    It is possible that port 25 is closed. This is something DigitalOcean has been doing to reduce spam on their network. Please do not think that they are accusing you of sending spam, it is more that they simply cannot accurately determine who is going to send it.

    Stopping spam is a constant fight, so DigitalOcean has implemented some restrictions on newer accounts. To qualify for the ability to send out emails, DigitalOcean requires accounts to wait 60 days before they can look into removing the restriction. Once your account has reached 60 days of stable use, please do reach back out to the DigitalOcean support team so they can look into this for you.

    In the meantime, you could use port 587 instead.

    Regards, Alex

      Hi

      i sent a ticket but your support team did’t answer after 3 days.