melkia666
By:
melkia666

owncloud broken

January 24, 2017 357 views
Apache Nginx Ubuntu

this is my first DO droplet and i was using owncloud and everything was fine it connected to the owncloud login and i was able to login. Then i added normal security measures like a new user and had ssh keys instead of a password. I did this on the server and i do not know why now when i try to login to own cloud i am now at the default niginx page. what should i do?

4 Answers
jtittle January 24, 2017
Accepted Answer

@melkia666

Questions:

  • Are you using Apache, NGINX, or both (i.e. NGINX proxying to Apache)?
  • How was Apache/NGINX setup (i.e. one-click or using apt-get from the CLI)?
  • What do you consider to be normal security measures? *

Why?

The first question I'm asking simply because you've tagged this question with both, but only mention NGINX in your comment. The second question is because directory structures may differ from the one-click and a repository package. The third is because adding a new user and setting up an SSH key should not cause Apache/NGINX to fail or revert back to the standard "success" page you see when the web server is first installed.

If you have this directory and Apache isn't actually installed...

/etc/nginx/sites-enabled

...please post the output of the default file (this is your default server block for NGINX). If NGINX is the only web server running and you've not configured any other server blocks, this is the one that should be pointing to where your website resides.

honestly i used set up the first droplet using the install the owncloud and i do have and i have this file like you said /etc/nginx/sites-enabled

so is apache2 not the one running the own cloud?

what confuses me is when i first boot up the system it did work i was able to login to my owncloud.

here is the server info that i cat.

i hope this helps you figure out whats wrong with my server thank you response

You may add here your server { } statements for each of your virtual hosts to this file You should look at the following URL's in order to grasp a solid understanding of Nginx configuration files in order to fully unleash the power of Nginx. http://wiki.nginx.org/Pitfalls http://wiki.nginx.org/QuickStart http://wiki.nginx.org/Configuration Generally, you will want to move this file somewhere, and start with a clean file but keep this around for reference. Or just disable in sites-enabled. Please see /usr/share/doc/nginx-doc/examples/ for more detailed examples.

server {
listen 80 defaultserver;
listen [::]:80 default
server ipv6only=on;

root /usr/share/nginx/html;
index index.html index.htm;

# Make site accessible from http://localhost/
server_name localhost;

location / {
    # First attempt to serve request as file, then
    # as directory, then fall back to displaying a 404.
    try_files $uri $uri/ =404;
    # Uncomment to enable naxsi on this location
    # include /etc/nginx/naxsi.rules
}

# Only for nginx-naxsi used with nginx-naxsi-ui : process denied requests
#location /RequestDenied {
#   proxy_pass http://127.0.0.1:8080;    
#}

#error_page 404 /404.html;

# redirect server error pages to the static page /50x.html
#
#error_page 500 502 503 504 /50x.html;
#location = /50x.html {
#   root /usr/share/nginx/html;
#}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
#location ~ \.php$ {
#   fastcgi_split_path_info ^(.+\.php)(/.+)$;
#   # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
#
#   # With php5-cgi alone:
#   fastcgi_pass 127.0.0.1:9000;
#   # With php5-fpm:
#   fastcgi_pass unix:/var/run/php5-fpm.sock;
#   fastcgi_index index.php;
#   include fastcgi_params;
#}

# deny access to .htaccess files, if Apache's document root
# concurs with nginx's one
#
#location ~ /\.ht {
#   deny all;
#}

}

another virtual host using mix of IP-, name-, and port-based configuration server { listen 8000; listen somename:8080; server_name somename alias another.alias; root html; index index.html index.htm; location / { try_files $uri $uri/ =404; } HTTPS server server { listen 443; server_name localhost; root html; index index.html index.htm; ssl on; ssl_certificate cert.pem; sslcertificatekey cert.key; sslsessiontimeout 5m; ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2; ssl_ciphers "HIGH:!aNULL:!MD5 or HIGH:!aNULL:!MD5:!3DES"; sslpreferserver_ciphers on; location / { try_files $uri $uri/ =404; }

@melkia666

From what you've posted, I'm not seeing where PHP-FPM is being configured and since OwnCloud is a PHP script, PHP has to be handled somehow, otherwise the script won't work (or shouldn't).

With just what you've posted, the only thing that would actually be handled are standard requests for HTML files (i.e. index.html), so if you're able to access OwnCloud at all, there has to be some sort of PHP configuration elsewhere that it's included in what you've provided. If you're not able to, then the configuration above is why you're not able to run the script.

The above files do not handle PHP requests at all. If you'll take at:

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
#
#location ~ \.php$ {
#   fastcgi_split_path_info ^(.+\.php)(/.+)$;
#   # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini
#
#   # With php5-cgi alone:
#   fastcgi_pass 127.0.0.1:9000;
#   # With php5-fpm:
#   fastcgi_pass unix:/var/run/php5-fpm.sock;
#   fastcgi_index index.php;
#   include fastcgi_params;
#}

This is part of what you'd normally use to handle PHP-FPM requests, but since it's commented out with # at the start of each line, there's no handling going on.

So my thoughts on this would be:

1). Something has been installed and it overwrote your configuration, or;
2). The installer that you used was interrupted or didn't complete, or;
3). There's something else at play, though it's hard to tell just based on the provided output.

DigitalOcean does have an OwnCloud one-click image that you can deploy when creating a Droplet. What I would recommend is deploying a new Droplet and when doing so, click on the header "One-Click Apps" next to "Distributions", then scroll down and find "OwnCloud 9.0.3" and use it to deploy a new instance.

Last I ran, the DigitalOcean instance does correctly set things up and that should help you to get a working installation setup and ready to use.

thank you for your help but a support just said to delete it because i modified something and start from scratch i mean thats fine thank you for your help :)

  • @melkia666

    No problem at all. I was leaning towards the same, though I didn't know if you had anything on the Droplet that you needed or if you could just destroy and restart. I always try to start by fixing and then as a last resort, start over :-).

Have another answer? Share your knowledge.