Php script running but not working

April 5, 2018 1k views
PHP Apache

I've installed php using this guide. It worked and my script seems to work with

php /var/www/html/folder/file.php 

At least it doesn't give me an error message. The script sends a get request to an outside API which is then written to a .txt file. I then read it on page load with javascript and display it on my site. The problem is that none of the text files get updated. It works on my local apache server that I set up on my computer, but not on my website.
I know it's probably better to use mySQL but that's not something I know how to do (though I am planning to learn).

2 Answers
ryanpq MOD April 5, 2018
Accepted Answer

The guide you followed is for a LAMP (Linux Apache MySQL PHP) environment but the command you are showing is attempting to run a php script from the command line. Ubuntu packages the command line and apache(mod_php) versions separately.

To install the CLI version of PHP you would need to run:

sudo apt-get update;
sudo apt-get install php-cli;
  • Thanks! Php works now, but my script still doesnt. Is there something else I need to do with the script or some way that I can debug it?

  • Hey, I've tried everything now, and it seems like it's fwrite that doesn't work. The script works but it doesn't actually write anything to the file. Could you point me in the right direction to help me solve this?

    • have you checked write permissions on the folder you're trying to write to?

      • I was using relative paths. I fixed it by switching to absolute. Thanks anyways!

Have another answer? Share your knowledge.