Question

PHPDesigner not working, because of old SSH, is there a hot fix?

Posted June 27, 2020 143 views
UbuntuPHPUbuntu 18.04

Hello,

I use PHPDesigner which I really love and i prefer not using another software for my PHP coding.

However PHPdesigner hasn’t been updated since 2013 which sucks because it uses some old SSH settings which it seems are not supported anymore.

The error I’m getting when trying to connect thru SFTP in PHPDesigner is

Server does not support diffie-hellman-group1-sha1 for keyexchange

I’ve tried adding some different things to the ssh config file but all fixes are too old to work.

So I’m hoping someone else can provide a way to get around this :)

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @Geekologist,

It looks like someone had the same question on the DigitalOcean community site a while ago, I would recommend checking the answer here:

https://www.digitalocean.com/community/questions/server-does-not-support-diffie-hellman-group1-sha1-for-keyexchange

Hope that this helps!
Regards,
Bobby

  • Hello, thanks for reply :)

    I’ve tried that already, but SSH has changed since he posted that, so it doesn’t work anymore :)

    I’ve already posted a comment on that answer that it doesn’t work anymore :)

    • Hi there @Geekologist,

      I think that it does not work because of the 3des-cbc and blowfish-cbc ciphers.

      Can you try with the following settings instead and let me know how it goes:

      KexAlgorithms diffie-hellman-group1-sha1,curve25519-sha256@libssh.org,ecdh-sha2-nistp256,ecdh-sha2-nistp384,ecdh-sha2-nistp521,diffie-hellman-group-exchange-sha256,diffie-hellman-group14-sha1
      Ciphers aes128-ctr,aes192-ctr,aes256-ctr,aes128-cbc,3des-cbc
      

      Regards,
      Bobby

Submit an Answer