PhpMyAdmin Remote Access

March 6, 2017 137 views
Apache Nginx Debian

Hi there,

Let me start by saying what I'm wanting to achieve: I have a Debian 8.7 droplet with nginx, apache, php and mysql installed as well as mcrypt. I am trying to have phpmyadmin active on a subdomain attached to the droplet. An example of this subdomain could be; pma.example.com.

So far, everything is set up (as far as I can tell). The only issue is when I go to the previously mentioned subdomain, the page that's opening, instead of displaying a webpage, downloads.

Example of my issue:

  1. I go to https://pma.example.com/phpmyadmin/
  2. The page closes.
  3. A download begins of the page.

Honestly, I'd attach snippets of some of the code I'm using. But I'm not sure what code is relevant. Feel free to request relevant snippets.

Cheers,
Brandon.

2 Answers
jtittle March 6, 2017
Accepted Answer

@keoisawsmn

If you're prompted to download the file you're attempting to access (i.e. index.php), then PHP is not working -- by that I mean PHP is not enabled or it's incorrectly setup. A downloaded file means that PHP files are not being processed, either by NGINX (PHP-FPM) or Apache (mod_php), so what you'll need to check and confirm is that PHP is indeed installed (and all required dependencies) and that it's enabled on the web server that's supposed to be processing PHP (which I'm guessing is Apache?).

So we can get a better idea of how you setup your Droplet, can you provide the tutorials, guides or steps you took to setup NGINX, Apache, and PHP?

If you set them up without a guide, please provide the commands used.

@jtittle
Hi Jonathan,

Thanks for you reply, with it comes my solution.

The problem was that I didn't edit my server block for the subdomain to handle .php files.

        location ~ \.php$ {
                        try_files $uri =404;
                        fastcgi_pass unix:/var/run/php5-fpm.sock;
                        fastcgi_index index.php;
                        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_sc$
                        include fastcgi_params;
        }

This is now solved.

Have another answer? Share your knowledge.