Question

Postfix: improper command pipelining after EHLO from unknown

I am attempting to access my email via Thunderbird and I get the following in /var/log/mail.log

Oct 14 13:27:22 baal postfix/submission/smtpd[15559]: warning: hostname cuda1.p2pa.com does not resolve to address 69.24.39.162
Oct 14 13:27:22 baal postfix/submission/smtpd[15559]: connect from unknown[69.24.39.162]
Oct 14 13:27:22 baal postfix/submission/smtpd[15559]: improper command pipelining after EHLO from unknown[69.24.39.162]: QUIT\r\n
Oct 14 13:27:22 baal postfix/submission/smtpd[15559]: disconnect from unknown[69.24.39.162]

What is causing this?

Additionally I am also getting the following from Dovecot when it starts in /var/log/mail.err

Oct 14 12:05:35 baal dovecot: auth: Error: read(anvil-auth-penalty) failed: EOF
Oct 14 12:05:35 baal dovecot: auth: Error: net_connect_unix(anvil-auth-penalty) failed: Permission denied

This is the tutorial I followed: https://www.digitalocean.com/community/tutorials/how-to-configure-a-mail-server-using-postfix-dovecot-mysql-and-spamassasin


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

For those who come here: I solved it by commenting out port=0 so that default imap settings becomes available /etc/dovecot/conf.d/10-master.conf: service imap-login { inet_listener imap { #port = 0 } … } I guessed correctly that somehow the imap protocol is being blocked somehow (You should also check the firewall) :)

At first, I thought I was experiencing problem with my configuration. Found this blog, and followed it.

But then I realized, that it is the way that Thunderbird checks for email settings during the first setup. It first checks and connect to IMAP on port 25 then port 143.

Well, in my case, I did not open port 25 and only use port 143 for IMAP, so it would be obvious that whenever Thunderbird checks port 25, it got rejected and made this error shows up in the log, but I do not have problems with authentication nor SSL, so I am just going to leave this like now, because I believe that my configuration is correct.

Here is mine:

service imap-login { inet_listener imap { port = 143 }

excellent solution. thanks a lot