Question

Prevention of Host Header Attacks with Nginx

  • Posted on September 9, 2020
  • Nginx
  • mspeAsked by mspe

I followed a tutorial on configuring Nginx to prevent host header attacks on Meduim. I placed the statement in the /etc/nginx/nginx.conf within the http section under server however curl request is still returning data and not the expected curl: (92) HTTP/2 stream 1 was not closed cleanly: INTERNAL_ERROR (err 2).

Nginx is running on 1.16.1

Is there anything else I need to add to the conf file or elsewhere? Apologises this is all me learning the hard way!


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Nevermind, figured it out after playing around with it and it seems work placed in the sites-enabled/mydomain file in the server section.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.