Problem connecting SQL Server Linux using SSMS


How do I connect to remote SQL Server using SSMS? I know this is a classic question, but i can’t seem to find any solution.

I created an Ubuntu 16.04 LEMP droplet and installed SQL Server Linux by following this example. I have tried connecting using sqlcmd -S localhost -U sa -P mypassword command, it works.

However, when I tried connecting using SSMS it gave me error: “A network-related or instance-specifi error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - The wait operation timed out.) (Microsoft SQL Server, Error: 258)

Note: I have set my firewall to allow incoming traffic on port for 1433 TCP

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hey friend!

I think it’s a bit outside of the intended use of the software, but there may be ways to force it to function. I’ve never done it, but I gravitate to confident answers and this one seemed pretty confident to me:

Hoping it helps :)