Question

Problem with openVPN easy-rsa

following the openVPN tutoria and step two keeps failing on something that seems very elementary, which is that it seems unable to find the file path. the code and error:


./easyrsa init-pki
-bash: ./easyrsa: No such file or directory

things I’ve tried: accessing as a different user, accessing from a different folder (rather than the cd ~/easy-rsa), modifying the vars path (currently it’s only the two lines recommended:


set_var EASYRSA_ALGO "ec"
set_var EASYRSA_DIGEST "sha512"

but I’ve tried that at the bottom, that plus set_var EASYRSA_PKI “$EASYRSA/pki”, and others but nothing happens. I expect this is a super easy item that I’ve missed somewhere, because I can’t find any other stack overflow questions specifically on it, or the like. so if there’s an easy fix that you all expect I’m all ears. thanks kindly.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi,

Being logged in as the user that you installed Easy-RSA with, check the content of the directory ~/easy-rsa:

ls -la ~/easy-rsa/

As you followed DO tutorial, you should get a couple of symbolic links (symlinks) as a result of the above command. These symlinks lead to the files in the directory /usr/share/easy-rsa/. There should be a symlink to easyrsa script there too. Check the script name. Check whether it exists in the directory /usr/share/easy-rsa/:

sudo ls -la /usr/share/easy-rsa/easyrsa*

Let us know how it is going, pls.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

additional info: tried

root@ubuntu:~/easy-rsa# sudo find ~/ -iname "easyrsa"
root@ubuntu:~/easy-rsa# sudo find / -iname "easyrsa"

neither returned anything, which makes me think that I missed an install somewhere but I’ve done:

sudo apt install openvpn easy-rsa
Reading package lists... Done
Building dependency tree       
Reading state information... Done
easy-rsa is already the newest version (2.2.2-2).
openvpn is already the newest version (2.4.4-2ubuntu1.3).
0 upgraded, 0 newly installed, 0 to remove and 16 not upgraded.

which was what every tutorial I’ve seen has…