prospect droplet better uptime woocommerce website

Hi Digital Ocean community,

Today I uploaded a WooCommerce XML shopping feed (400 products) to the facebook business shopping catalogue and while doing this it made the website unreachable.

I assume it was unreachable because facebook was downloading the catalogue from the XML feed (can see facebook has uploaded the primary product image onto facebook).

Where in the apache logs can I find what caused the website to stop loading for users? It was timing out.

What can be done to prevent the DigitalOcean server being unreachable in the future? Would the droplet need upgrading? If yes what specs?

I was thinking about creating a new droplet solely for this WooCommerce website or upgrading the current one. The droplet its currently on has other website on it but they aren’t very demanding traffic wise.

This is the current droplet specs -

1 GB / 1 CPU Shared
25 GB Disk

Looking at the create droplet options would a dedicated CPU be best? I think the $40 month CPU-Optimized droplet is best pricewise (cheapest) -

4 GB / 2 CPUs
25 GB SSD Disk
4 TB transfer

Or would a shared CPU with the other Intel / AMD CPU options be viable? For example Premium Intel with NVMe SSD for $24 -

4 GB / 2 Intel CPUs
4 TB transfer

Would there be a noticeable difference between the shared CPU and the dedicated CPU?

Are both droplet options good enough to prevent the server from being unreachable as described above?

What droplet option can withstand the most traffic?

Thanks in advance to anyone that can answer any of these questions!!

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello @twc8ac35a8636,

I’ve not received the message.

In theory there shouldn’t be a limit of the max allowed cinema seats. The more powerful your Droplet is, the more it can handle.

As for the Googe Page Speed Score, I don’t think that both are connected in that way.

Hi @twc8ac35a8636,

So, you can increase the Apache Workers as much as you like on a Droplet even if it’s not that powerful. If it will handle the traffic is another question. This solely depends on how heavy your websites are and how much CPU and Memory they require on a load.

So, how I proceed with such cases, I increase the Apache Workers until I notice some high load with the Droplet. Then I know it’s limit and lower the Apache Workers a bit. If that limit is not enough for you though, then thinking about upgrading your Droplet is the proper way to go!

As for the Google Insights, I don’t think it detects bigger Droplets and CPU utilization.

Hi @twc8ac35a8636,

It sounds like you filled up your ApacheWorkers.

So first, what are Apache Workers and what are they used for:

Imagine you are in a cinema, and there are 300 chairs inside. Those are the Apache Workers and the movie is your Webiste. If someone wants to watch the movie(your website) they need to sit in the chair (Apache Workers). If all 300 chars are taken, the 301 person needs to wait for someone to leave in order for them to sit and watch the movie. That’s how ApacheWorkers work. Once all ApacheWorkers are taken, a new person that wants to open your website waits for a spot to be open and only after that they can see your website.

Usually, these limits are set by 256 by default but they can be increased.

You can open your Apache configuration file. In there you should see something similar to:

ServerLimit 256
MaxClients 256
MaxRequestsPerChild 4000

Increase both the ServerLimit and MaxClients options, restart Apache, and see if this would solve your issue.

It’s possible they do not exist (haven’t been added) and the default values are the ones above. Adding them to the prefork content of apache mods should be fine as well.

Don’t forget to restart Apache afterward.

Regards, KFSys