Question

PTR record for IPv6?

Hello , i configure my PTR record to my ip4 but i dont see the same for my ipv6. i change my /etc/hosts parametrer.

change my sudo nano /etc/network/interfaces iface eth0 inet6 static address primary_ipv6_address netmask 64 gateway ipv6_gateway autoconf 0 dns-nameservers 2001:4860:4860::8844 2001:4860:4860::8888 209.244.0.3

But nothing happend ? what i miss ?

Thx

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Accepted Answer

Hello, @jobuu

The Reverse DNS for the IPv4 is configured automatically from our end based on the droplet’s hostname.

The support for PTR records for IPv6 addresses was actually added a while back. By default, the each Droplet with IPv6 enabled will be configured with a single IPv6 address. This is the address that will be used for any PTR records that will be generated for domains pointing at your server. Like with IPv4, if the hostname given to the Droplet is a FQDN, the PTR record will be generated automatically.

Regards, Alex

To set the PTR for the IPv6 address:

All you need to do is temporarily change the name (Domain) of your droplet to something other than what it was set to when you enabled IPv6.

Then wait 1 minute, and change it back to the Domain Name you originally set it to before adding IPv6.

For example:

My domain was set to ser1.example.com. I enabled IPv6. I would change the domain to temp.example.com. Wait 1 minute. Then Change the domain back to ser1.example.com.

I hope that this finally resolves your issue.

Sincerely, Adam

Ty alex!