Question

regarding to usage way of UFW in NGINX

  • Posted on February 1, 2015
  • junukseoAsked by junukseo

hello, I use ubuntu 14.04 version and I read article on

https://www.digitalocean.com/community/tutorials/how-to-setup-a-firewall-with-ufw-on-an-ubuntu-and-debian-cloud-server, got some curios thing that I would like to know usage of UFW

first question is I chaged basic port 22 to 2345 that I access /etc/ssh/sshd_config after restart ufw, opened ssh port through Ufw allow ssh. but keep opened 22 port do I have to open ssh port to ufw allow 2345 after block 22 port using by ufw deny 22?

and second question is i tried to access using 2345 port on sftp

actually it is possible to download, upload file on ftp through Root account. but after made my

account suddely showed up message 'Deny permission and can not upload and download.

how can I get permission?

below is my last question. google bot or cloudflare’s ip automatically block when enable ufw. should I each and every time open

by using ufw allow ip/port?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

If you have changed the SSH port in /etc/ssh/sshd_config, you will need to explicitly tell UFW what port to use:

sudo ufw allow 2345
sudo ufw deny 22
sudo service ufw restart

You will also need to tell your FTP client to connect via SFTP on that port as well. By default, it will try to use port 22.