Hello,

I’m not sure if this has been posted yet?

But whenever I try uploading a file over I would say 500MB from my website using the AWS PHP SDK kit for DigitalOcean Spaces; I ultimately get the error:

413 Request Entity Too Large
--------
nginx

The website is using a custom made PHP script in which I have coded.

I’ve checked my php.ini file and my settings are set too:

file_uploads = On
max_execution_time = 300
max_file_uploads = 2000
max_input_time = 6000
memory_limit = 12000008M
post_max_size = 1000000M
upload_max_filesize = 1000000M

Am I missing something? Or does anyone have an idea why I can’t upload large items?

1 comment
  • After some digging I just discovered that I don’t think it’s on the end of Spaces but my server? I’ve commented out the Spaces Folders and tried uploading the files to just the temp folder. I still get that error. This is leading me to think it’s just an issue with the php.ini? However, I have printed out the phpinfo() on my site and everything looks as it should?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers
Show answer This answer has been marked as resolved by DevLexicon.

Hi there @DevLexicon,

You would need to update your Nginx configuration and increase the client_max_body_size.

To do that open the /etc/nginx/nginx.conf file:

  • sudo nano /etc/nginx/nginx.conf

And inside the http { block add the following line:

client_max_body_size 500M;

After that run an Nginx config test:

  • sudo nginx -t

And if you get Syntax OK restart Nginx:

  • systemctl restart nginx

Let me know how it goes!
Regards,
Bobby

Submit an Answer