Good Morning,

I created a mysql managed database (open to all incoming connections/raw initial setup). I then created a one-click phpmyadmin droplet from the marketplace, as I would like to create a web-based ui for managing my mysql managed database as I use chrome os more often than not, and would prefer to not use desktop apps for accessing and managing my databases/web projects in general and keep my development process browser-based.

I then updated the phpmyadmin mysql to mysql 8, and tried to add the managed database server to the /etc/phpmyadmin/config.inc.php file. i.e.:
$i++;
$cfg[‘Servers’][$i]['verbose’] = 'CLUSTER’;
$cfg['Servers’][$i]['host’] = 'nottheprivatehost-0.db.ondigitalocean.com’;
$cfg['Servers’][$i]['port’] = 25060;
$cfg['Servers’][$i]['socket’] = “;
$cfg['Servers’][$i]['auth_type’] = 'config’;
$cfg['Servers’][$i]['ssl’] = true;
$cfg['Servers’][$i]['user’] = 'doadmin’;
$cfg['Servers’][$i]['password’] = 'mypassword’;

However, no matter what I add or modify, I cannot get the new server database to appear anywhere on ip/phpmyadmin when logging in or when logged on.

My primary question would be what I am missing in terms of the connection details for the config file or if I need to update another file somewhere or something else I am missing completely.

But also if anyone has any recommendations about better alternatives then phpmyadmin for a browser-based database manager ui for mysql, that would be some-what easy for a novice like myself to install and use, I wouldn’t mind going that route either.

I do like phpmyadmin and am familiar with it, and figured the one-click is decent enough to use.

Any help and/or guidance would be much appreciated.

Thank you,

-Matt

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi there @meloku,

I think that the PHPmyAdmin that ships with Ubuntu 18.04 has some issues connecting to MySQL 8, what you could do instead of using the 1-Click PHPmyAdmin install is to just install PHPmyAdmin manually so that you get the latest PHPmyAmin version.

You can follow the steps here:

https://www.digitalocean.com/community/questions/how-to-install-manually-phpmyadmin-on-ubuntu

Also, note that you might have to change caching_sha2_password to mysql_native_password for your MySQL user so that PHPmyAdmin could connect to your managed cluster, you can follow the steps on how to do that here, it also includes a short video demo:

https://www.digitalocean.com/community/questions/how-to-change-caching_sha2_password-to-mysql_native_password-on-a-digitalocean-s-managed-mysql-database

What I could suggest is rather than using PHPmyAdmin is to use an application like dbeaver or table plus. The downside is that you need to install the applications on your PC.

Let me know how it goes!
Regards,
Bobby

  • Hi Bobby,

    I took your advice and walked through your tutorials and created a new droplet with a lemp stack and installed phpmyadmin manually.

    I have to say although it seemed like a lot for someone like myself to handle, it went very smoothly, big thanks to your step by step guides :).

    The only issue I ran into was when I was installing php, the “php-mcrypt” would cause an error and would not finish or initialize the install. I didn’t catch it right away until I started testing out the info.php page.

    sudo apt-get install php libapache2-mod-php php-mcrypt php-mysql

    I just removed that package and the install seemed to work fine, but I am not sure if I should install a similar package…

    Overall, I do feel better about doing it this way, as now I do understand quite a bit more of what is happening behind the scenes, and the fact I can setup a lets encrypt cert with a custom domain is a nice benefit.

    Also, it seems that digitalocean allows for the changing of cachingsha2password to mysqlnativepassword right on the users tab of the managed databases dashboard as a dropdown now, which is a nice touch.

    Much appreciate your help and response.

    Thank you

    -Meloku

    • Hi there @meloku,

      This is great, I am happy to hear that you’ve managed to get this all working and that you’ve learned new things along the process!

      Regarding the mcrypt module, as far as I can see from the official PHP.net website, the mcrypt extension has been abandonware for a long time and was also fairly complex to use. It has therefore been deprecated in favor of OpenSSL, where it will be removed from the core and into PECL in PHP 7.2.

      Regards,
      Bobby

Submit an Answer