Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

We have a Zend/PHP app hosted on a droplet. Recently the app has been crashing on average every six hours; the browser won’t connect. We haven’t really made any changes to the droplet/server or the app. Restarting Ubuntu brings it right back up, but I’m trying to get to the root cause here. This is in /var/apache2/error.log right before the crash every time:
[Sat Sep 21 07:11:29.055079 2024] [mpm_prefork:notice] [pid 1034] AH00171: Graceful restart requested, doing restart
(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
(98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
[Sat Sep 21 07:11:29.071225 2024] [mpm_prefork:alert] [pid 1034] no listening sockets available, shutting down
[Sat Sep 21 07:11:29.071231 2024] [:emerg] [pid 1034] AH00019: Unable to open logs, exiting
[Sat Sep 21 07:11:33.376569 2024] [core:warn] [pid 28319] AH00098: pid file /var/run/apache2/apache2.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Sep 21 07:11:33.380530 2024] [mpm_prefork:notice] [pid 28319] AH00163: Apache/2.4.41 (Ubuntu) OpenSSL/1.1.1f configured -- resuming normal operations
[Sat Sep 21 07:11:33.380572 2024] [core:notice] [pid 28319] AH00094: Command line: '/usr/sbin/apache2'
ebeecroft
Noor Bakkal
384d3f11289345379905a243f7b817
IsaacMvd
Ervan Agus
Teckno
dc1bce8262314f84b368813178d9e4
gerard
gerard
Stan Flint